node.js

  • antlr4-graps, the Node.js module

    With the increasing popularity of Node.js I thought it would be a good idea to have a native module which provides language parsing services for ANTLR4 grammar files, utilizing a fast C++ backend. This could then be used in IDEs/editors to provide ANTLR4 language support. Additionally, I wanted to create an extension for Visual Studio Code for ANTLR4 grammars, so I started writing one.

    The module itself is quite small and you can read a detailed description in its Github repository. The installation follows the usual procedure via npm (npm install antlr4-graps). However, since it is a native module, you need a compiler at hand to allow compilation during an installation. On Linux this is usually no problem. On OSX/macOS you have to have XCode installed, while on Windows you either need Visual Studio or the free build tools. Search the web if you wanna know how to build native Node.js modules on Windows, if you need help. To ease usage I have a second branch in the git repo which doesn't contain the sources, but prebuilt binaries. Note however that this branch is not published as own Node.js module.

    I hope you like it.

  • Updates for ANTLR4 Node.JS/Visual Studio Code tools now available

    Recently Sam Harwell released the ANTLR4 Typescript runtime as a Node.JS module, which opens a great way to implement ANTLR support in Node.JS modules and Visual Studio Code extensions. I took the opportunity and rewrote my antlr-graps Node.JS module and my vscode-antlr4 extension. If you are working with Visual Studio Code and want ANTLR grammar support in it then go ahead and install the extension. While it's on a good way it still cannot compete with IDEs like antlrworks2 (also written by Sam Harwell).